In the middle of May the company MetaQuotes released a new version of the trading platform MetaTrader4. We inform you about the need to update your version of the terminal because the versions which are older than the 500th MetaTrader4 will be no longer supported since 1st August, 2013.

We urge you to install and download the 500th version of MetaTrader4 in advance in order to continue trading in the terminal without any difficulty.

Regards,
LiteForex Сompany

 

Notification: the necessity to upgrade the version of the MetaTrader4 trading platform before 1st August

Notification: the necessity to upgrade the version of the MetaTrader4 trading platform before 1st August
Follow us in social networks!
Live Chat
Leave feedback