Marginal requirements may be increased for the pairs with GBP and stock indices

Dear clients!

Please be advised that in connection with an extremely uncertain situation around Brexit vote in the UK, there is a possibility of a sharp increase in volatility in the currency and stock markets.

In this regard, the company reserves the right to increase the margin requirements on all LiteForex trading servers for the following instruments: all currency pairs with GBP, stock indices (FDAX, CAC, SX5E, IBEX35). Price gaps and spreads extensions are also possible.

Please take this information into account when making trading decisions and follow the news on the official LiteForex website.

 

Sincerely yours,
LiteForex Investments Limited

 

Possible changes in margin requirements due to Brexit
Start Trading
Follow us in social networks!
Live Chat
Leave feedback